Перейти к основному содержанию

Скачать

Содержание

Скомпилированный CSS и JS

Загрузите готовый к использованию скомпилированный код для Bootstrap v5.0.1, чтобы легко вставить его в свой проект, который включает:

Это не включает документацию, исходные файлы или любые дополнительные зависимости JavaScript, такие как Popper.js.

Скачать

Исходные файлы

Скомпилируйте Bootstrap с вашим собственным конвейером ресурсов, загрузив наши исходные файлы Sass, JavaScript и документации. Для этого варианта требуются дополнительные инструменты:

Если вам потребуются инструменты сборки , они включены для разработки Bootstrap и документации к нему, но, скорее всего, они не подходят для ваших собственных целей.

Скачать исходный код

Примеры

Если вы хотите скачать и изучить наши примеры, вы можете взять уже построенные примеры:

Скачать примеры

Bootstrap CDN

Пропустите загрузку с помощью BootstrapCDN, чтобы предоставить вашему проекту кешированную версию скомпилированных CSS и JS Bootstrap.

<link href="https://cdn.jsdelivr.net/npm/bootstrap@5.0.1/dist/css/bootstrap.min.css" rel="stylesheet" integrity="sha384-+0n0xVW2eSR5OomGNYDnhzAbDsOXxcvSN1TPprVMTNDbiYZCxYbOOl7+AMvyTG2x" crossorigin="anonymous">
<script src="https://cdn.jsdelivr.net/npm/bootstrap@5.0.1/dist/js/bootstrap.bundle.min.js" integrity="sha384-gtEjrD/SeCtmISkJkNUaaKMoLD0//ElJ19smozuHV6z3Iehds+3Ulb9Bn9Plx0x4" crossorigin="anonymous"></script>

Если вы используете наш скомпилированный JavaScript, не забудьте включить Popper.js, желательно через CDN, перед нашим JS.

<script src="https://cdn.jsdelivr.net/npm/@popperjs/core@2.9.2/dist/umd/popper.min.js" integrity="sha384-IQsoLXl5PILFhosVNubq5LC7Qb9DXgDA9i+tQ8Zj3iwWAwPtgFTxbJ8NT4GN1R8p" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/bootstrap@5.0.1/dist/js/bootstrap.min.js" integrity="sha384-Atwg2Pkwv9vp0ygtn1JAojH0nYbwNJLPhwyoVbhoPwBhjQPR5VtM2+xf0Uwh9KtT" crossorigin="anonymous"></script>

Менеджеры пакетов

Загрузите исходные файлы Bootstrap практически в любой проект с помощью некоторых из самых популярных менеджеров пакетов. Независимо от менеджера пакетов, Bootstrap потребует компилятор Sass и Autoprefixer для настройки, соответствующей нашим официальным скомпилированным версиям.

npm

Установите Bootstrap в приложения на базе Node.js с пакетом npm:

npm install bootstrap@next

const bootstrap = require('bootstrap') or import bootstrap from 'bootstrap' загрузит все плагины Bootstrap в bootstrapобъект. Сам bootstrapмодуль экспортирует все наши плагины. Вы можете вручную загрузить плагины Bootstrap по отдельности, загрузив /js/dist/*.jsфайлы в каталог верхнего уровня пакета.

Bootstrap package.jsonсодержит некоторые дополнительные метаданные под следующими ключами:

yarn

Установите Bootstrap в свои приложения на базе Node.js с пакетом yarn:

yarn add bootstrap

RubyGems

Установите Bootstrap в свои приложения Ruby с помощью Bundler ( рекомендуется ) и RubyGems , добавив следующую строку в ваш Gemfile:

gem 'bootstrap', '~> 5.0.1'

В качестве альтернативы, если вы не используете Bundler, вы можете установить гем, выполнив эту команду:

gem install bootstrap -v 5.0.1

Смотри документацию для получения дополнительной информации.

Composer

Вы также можете установить Sass и JavaScript для Bootstrap и управлять ими с помощью Composer:

composer require twbs/bootstrap:5.0.1

NuGet

Если вы разрабатываете в .NET, вы также можете установить CSS или Sass и JavaScript для Bootstrap и управлять ими с помощью NuGet:

Install-Package bootstrap
Install-Package bootstrap.sass
Комментарии для сайта Cackle